LiveUpdate error LU1825 for BackupExec 2012

I've installed BackupExec 2012 on a clean server (Windows 2008 R2 SP1) and get an error when running Live Update. This is what it says:

Error: LU1825: This update was corrupted so LiveUpdate was unable to process it...

There are only two updates available and it starts to download and install them but fails about half way through:

Hotfix 182237
Hotfix 182395

Anyone have any ideas?