KMS question

Hello. I have setup KMS on a Windows 2008 R2 server but none of my clients appear to be licensed. I have installed the key, which it reported as being successful, and I have activated the product successfully, yet none of the clients can activate. Can anyone provide any suggestions as to what I am missing please?

Comments

  • 6 Comments sorted by
  • Vote Up0Vote Down

    On the server hosting the KMS service are there any entries in the Key Management Service event log?  Each activation attempt will be logged in here.

  • Vote Up0Vote Down

    This is a good place to start for using KMS:

    http://technet.microsoft.com/en-us/library/cc303280.aspx#_Install_KMS_Hosts

    If you run CSCRIPT C:\Windows\System32\SLMGR.VBS /DLV ALL it should show the license status.

  • Vote Up0Vote Down

    Dave, no, there are no entries in that log, it is empty.

    Cocker, thanks for the link, I'll have a read.

  • Vote Up0Vote Down
    OK, I now have some clients activating successfully, I see the Event ID 12290 entries stating that an activation request has been processed. However, some clients still fail with this message:

    A problem occurred when Windows tried to activate. Error Code 0xC004F074
  • Vote Up0Vote Down
    What operating system are you trying to activate?  This may be a version mismatch and need a patch on the KMS host,  See http://support.microsoft.com/kb/974998/en-gb
  • Vote Up0Vote Down

    They are all Windows 2008R2.  I think the errors may be caused by firewall issues as they are all at remote sites, I will have my firewall team investigate.

    When I run CSCRIPT C:\Windows\System32\SLMGR.VBS /DLV ALL I see this in the output:

    Total requests received: 27
    Failed requests received: 0
    Requests with License Status Unlicensed: 0
    Requests with License Status Licensed: 1
    Requests with License Status Initial grace period: 26
    Requests with License Status License expired or Hardware out of tolerance: 0
    Requests with License Status Non-genuine grace period: 0
    Requests with License Status Notification: 0

    Is this OK? Should they show as being in the grace period or should they show as licensed?

  • Vote Up0Vote Down
    Update: the clients failing to activate with Error Code 0xC004F074 are working now, this was a networking issue.